Improving Fury video card compatibility

- Ben Houston

The release today is a minor one. This release focuses solely on improving the stability of Fury on a variety of video cards. Fixing these issues has usually involved purchasing the video card in question and then running Fury and reproducing the issue. The main video cards for which this release significantly improves stability are the following:

  • GeForce GTS 480
  • GeForce GTS 470
  • GeForce GTS 465
  • GeForce GTS 460
  • GeForce GTX 285
  • GeForce 9600
  • GeForce 8800
  • Quadro FX 570
  • ATI Radeon HD 4800

This release likely improves stability for other NVIDIA video cards not listed as well, but these are the specific video cards that we targeted based on the automatic error reports we received. We always recommend running with the latest video drivers.

We are aware an unresolved issue with GeForce 9800 / Quadro 1800 series video cards (involving intermittent freezes when rendering multiple passes) and are working to fix it as soon as possible.

As usual, you can download the latest release from here:

http://www.exocortex.com/simulation/slipstreamvx

Exocortex Blog

This is the blog of Exocortex, passionate CG software professionals creating tools for top artists, developers and studios.

View all our blog entries.

Browse our products.